Snaží vyvinout python v Emacsu

hlasů
4

Snažím se sledovat nastavení na http://hide1713.wordpress.com/2009/01/30/setup-perfect-python-environment-in-emacs/

Mám kroky 1-3 běží skvěle.

Pak jsem se dostat do části 4: Nastavení Rope, Ropemacs a Pymacs.

Musíme nejnovější vývojovou verzi Lanové a Ropemacs. V opačném případě, emacs nemůže najít funkci lano-dokončených ploch. Jen jsem copy'n pastu z internetových stránek Ryana. Najdete původní příspěvek zde

sudo apt-get install mercurial
mkdir /tmp/rope && cd /tmp/rope
hg clone http:// bitbucket . org/agr/rope
hg clone http:// bitbucket . org/agr/ropemacs
hg clone http:// bitbucket . org/agr/ropemode
sudo easy_install rope
ln -s ../ropemode/ropemode ropemacs/
sudo easy_install ropemacs

Používám GNU Emacs 22.0.97.1 na OS 10.4.11

Snažil jsem se běží to přes terminál, ale i získat došlo k chybě: sudo apt-get: command not found

Položena 23/12/2010 v 03:55
zdroj uživatelem
V jiných jazycích...                            


3 odpovědí

hlasů
3

apt-get je pouze na systémech Debian bázi, jako je Ubuntu a * buntu. distribuce RPM použít celou řadu dalších systémů, ale zdá se yum se převládající.

Vzhledem k tomu, že jste na Mac, nainstalovat MacPorts . Budete muset nejprve nainstalovat XCode, které můžete získat od společnosti Apple po registraci (zdarma).

Odpovězeno 23/12/2010 v 04:01
zdroj uživatelem

hlasů
2

Zkusit se el-get, že je to opravdu pěkné instalovat a udržovat všechny své Elisp rozšíření up-to-date.

Odpovězeno 23/12/2010 v 04:12
zdroj uživatelem

hlasů
1

No, apt-get je správce balíčků pro systémy Linux Debian bázi. Nebude existovat na většině Mac. Jakýchkoli programů Ryan chce instalovat (pomocí apt-get), budete muset pokusit nainstalovat do vhodným způsobem pro Mac OS X.

Měli jste na mysli jste používáte operační systém Mac OS X, že jo?

Odpovězeno 23/12/2010 v 04:00
zdroj uživatelem

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more