Jak odkazovat V2.0.0 balíčku Go, který nedrží hlavní dílčí složky konvence jako modul

hlasů
0

Jsme běží bodec zjistit, jak nebo dokonce, jestli můžeme přenést naše stack Go modulů. Jsme závislí na v2.0.0 https://github.com/gbrlsnchs/jwt , ale to není ani přestavěná na samotném modul ani dodržovat Go konvence uvedení hlavní verze na základě dílčích složek.

Jaké jsou naše možnosti tady, když to přijde ke konverzi náš vnitřní obal na modul, který má tuto závislost?

Položena 27/11/2018 v 17:51
zdroj uživatelem
V jiných jazycích...                            


1 odpovědí

hlasů
1

github.com/gbrlsnchs/jwtna v2.0.0vlastní go.modsoubor, který označuje, že její kanonický import cesta github.com/gbrlsnchs/jwt/v2.

Aktualizovat své importprohlášení používat tuto cestu - což by mělo rovněž pracovat v režimu GOPATH v Go 1.9.7, 1.10.3, 1.11.0, a především za použití „ minimální kompatibilitu modulu “ - a vy byste měli být dobré jít.

Odpovězeno 19/08/2019 v 21:31
zdroj uživatelem

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more