Nelze upgradovat pip 1.5.4 na Ubuntu 14.04 - InsecurePlatformWarning: Skutečný objekt SSLContext není k dispozici

hlasů
2

Já jsem v současné době běží PIP, verze 1.5.4 na Ubuntu 14.04 a Python 2.7.6 a nemohou přejít pip na nejnovější verzi.

Když spustím pip nainstalovat --upgrade PIP dostanu následující chybu:

Cannot fetch index base URL https://pypi.python.org/simple/ Could not find any downloads that satisfy the requirement pip in ./.venv/lib/python2.7/site-packages Downloading/unpacking pip Cleaning up... No distributions at all found for pip in ./.venv/lib/python2.7/site-packages Storing debug log for failure in /home/buffcat/.pip/pip.log

A když se snažím aktualizovat pomocí get-pip.py dostanu následující Chyba SSL:

/tmp/tmpKVfWOr/pip.zip/pip/_vendor/urllib3/util/ssl_.py:369: SNIMissingWarning: An HTTPS request has been made, but the SNI (Server Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings /tmp/tmpKVfWOr/pip.zip/pip/_vendor/urllib3/util/ssl_.py:160: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:510: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed'),)': /simple/pip/

Co mohu udělat pro upgrade pip na mém počítači?

Položena 27/11/2018 v 17:52
zdroj uživatelem
V jiných jazycích...                            


1 odpovědí

hlasů
1

I když se nedoporučuje upgradovat systém Ubuntu pip(jeden z rozvodné dodaný Ubuntu python-pipinstalačního balíčku) obchází apt-get, to je přijatelné, aby tak učinily v venv / VIRTUALENV nebo si uživatelské úrovni domácí dir (dále jen --uservolba PIP). Tento způsob umožňuje, aby jej použít, aniž by v rozporu s „systém“ pip. Zdá se, že jste pracovali Uvnitř virtualenv, což je dobré praxe.

SSLError je způsobeno tím, že základem OpenSSL verze knihovny vašeho systému <1.0.1 a Python verzí <2.7.9 nepodporují novější TLS protokol verze 1.2 , která PyPI očekává od asi před rokem. A tak pipse nemůže připojit k PyPI přes starší SSL / TLS protokoly déle.
Můžete zkontrolovat verze s:
$ python -c "import ssl; print(ssl.OPENSSL_VERSION)" && openssl version
Chyba může být reprodukován i bez pip, něco jako:
$ curl -i https://pypi.org/simple/ --tlsv1
curl: (35) chyby: 1409442E: SSL rutiny: SSL3_READ_BYTES: TLSv1 upozornění verzi protokolu

Vzhledem k tomu, pip se nemůže připojit k PyPI, můžeme jej aktualizovat ručně:

  • Ve Firefoxu, otevřete Python Index Package oficiální webovou stránku a lokalizovat projekt pip ,
  • Vyberte „Stahování souborů“ existuje - je zde přímá vazba: https://pypi.org/project/pip/#files
  • Kliknutím na nedávném souboru pip obalu kola formátu ( .whl ) ke stažení,
  • Nainstalovat do venv / VIRTUALENV jste pracovali například na tom:

        $ source bin/activate
        (venv) $ pip install --no-index ~/Downloads/pip-19.0.1-py2.py3-none-any.whl
        (venv) $ pip --version
         pip 19.0.1 from ...
    

Ale modernizace / instalaci novější verze pip je napůl vyhráno. Pro to, aby bylo možné se připojit k PyPI, musíme vyřešit příčinu: ZAŘÍZENÍ InsecurePlatformWarning .. Caused by SSLError .. SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'. Chcete-li jej opravit, budete muset ručně nainstalovat (stejným způsobem) další balíčky kromě pip. Podrobnou krok za krokem průvodce zde na StackOverflow: Nelze nainstalovat Python balíky pomocí pip v Ubuntu Linux: InsecurePlatformWarning, SSLError, TLSv1 alert verze protokolu

Odpovězeno 08/02/2019 v 20:17
zdroj uživatelem

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more