po upgradu z 8 na 9 ng chyba sestavení: Import neočekávaného symbolu invalidFactory při kompilaci úhlu / jádra

hlasů
0

po provedení úhlové aktualizace se zobrazí následující chyba:

Kompilace modulu @ angular / core: core as esm5 Error: Error on worker # 2: Error: Import neočekávaného symbolu ɵɵinvalidFactory při kompilaci @ angular / core na Object.validateAndRewriteCoreSymbol (C: \ sites \ regent-dev \ Web \ Desktop \ DesktopModules \ RegentApp \ node_modules @angular \ compiler-cli \ src \ ngtsc \ import \ src \ core.js: 90: 19)

Spustil jsem aktualizaci @ angular / cli @ 9 @ angular / core @ 9 - vynutit upgrade z 8 na 9, protože se vyskytly problémy se vzájemnou závislostí.

Jakmile to bylo provedeno, spustil jsem sestavení a objevila se výše uvedená chyba. Takže jsem se snažil opravit to:

  • vrácení všech změn
  • odstranit node_modules složku rm -rf node_modules
  • odstranit package-lock.json soubor
  • npm i
  • npm install @angular/cli -g
  • ng update @angular/cli @angular/core --force
  • ng update --all --force

Chyba se stále zobrazuje

Může mi někdo pomoci zjistit, co se tady děje?

Díky předem

Zde je chyba, která bude vyvolána při spuštění postinstall ngcc

$ npm i

> my-app@1.3.51 postinstall C:\sites\...\App
> ngcc

Warning: Entry point '@angular/core' contains deep imports into 'C:/sites/.../node_modules/ng2-bootstrap-growl/node_modules/rxjs/symbol/observable', 'C:/sites/.../node_modules/ng2-bootstrap-growl/node_modules/rxjs/Subject', 'C:/sites/.../node_modules/ng2-bootstrap-growl/node_modules/rxjs/Observable'. This is probably not a problem, but may cause the compilation of entry points to be out of order.
Compiling @angular/core : fesm2015 as esm2015
Compiling @angular/core : main as umd
Error: Error on worker #2: Error: Importing unexpected symbol ɵɵinvalidFactory while compiling @angular/core
    at Object.validateAndRewriteCoreSymbol (C:
... Stack Trace Continues ...

toto je moje úhlová verze (po aktualizaci a ta, která hází chybu):

Angular CLI: 9.1.7
Node: 10.15.0
OS: win32 x64

Angular: 9.1.9
... animations, common, compiler, compiler-cli, core, forms
... platform-browser, platform-browser-dynamic, platform-server
... router
Ivy Workspace: Yes

Package                           Version
-----------------------------------------------------------
@angular-devkit/architect         0.901.7
@angular-devkit/build-angular     0.901.7
@angular-devkit/build-optimizer   0.901.7
@angular-devkit/build-webpack     0.901.7
@angular-devkit/core              9.1.7
@angular-devkit/schematics        9.1.7
@angular/cdk                      9.2.4
@angular/cli                      9.1.7
@ngtools/webpack                  9.1.7
@schematics/angular               9.1.7
@schematics/update                0.901.7
rxjs                              6.5.5
typescript                        3.9.3
webpack                           4.42.0
Položena 25/04/2020 v 23:13
zdroj uživatelem
V jiných jazycích...                            

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more